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is prohibited.
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any application made of this information and any resulting product. Cypress products are not designed, intended, or autho-
rized for use as critical components in systems designed or intended for the operation of weapons, weapons systems, nuclear
installations, life-support devices or systems, other medical devices or systems (including resuscitation equipment and surgi-
cal implants), pollution control or hazardous substances management, or other uses where the failure of the device or system
could cause personal injury, death, or property damage ("Unintended Uses"). A critical component is any component of a
device or system whose failure to perform can be reasonably expected to cause the failure of the device or system, or to
affect its safety or effectiveness. Cypress is not liable, in whole or in part, and you shall and hereby do release Cypress from
any claim, damage, or other liability arising from or related to all Unintended Uses of Cypress products. You shall indemnify
and hold Cypress harmless from and against all claims, costs, damages, and other liabilities, including claims for personal
injury or death, arising from or related to any Unintended Uses of Cypress products.

Cypress, the Cypress logo, Spansion, the Spansion logo, and combinations thereof, WICED, PSoC, CapSense, EZ-USB, F-
RAM, and Traveo are trademarks or registered trademarks of Cypress in the United States and other countries. For a more
complete list of Cypress trademarks, visit cypress.com. Other names and brands may be claimed as property of their respec-
tive owners.
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The KitProg is an onboard programmer/debugger with USB-12C and USB-UART bridge functionality.
The KitProg is integrated onto most PSoC development kits. This user guide provides
comprehensive information on how to use the KitProg functionalities with PSoC development kits.

Figure 1-1 shows the KitProg Ecosystem. The Cypress PSoC 5LP device is used to implement the
KitProg functionality.

Figure 1-1. KitProg Ecosystem

4 N
KitProg
4 PSoC 5LP N
Status LED CY8C5868LTI-LP039
PC USB Host =< e N\ Cypress Target Device
USB HID
Bootloader
PSoC Creator < 0] » XRES
PSoC Programmer USB KitProg Application WD » SWD
< > L UART o
Bridge Control Panel SWD Programmer < e UART RX/TX
- ; SWD Debugger < » 12C
Serial Terminal USB-UART Bridge
USB-I12C Bridge
File Explorer Mass Storage
Programmer
- J
o %
N J
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Table 2-1 lists the development kits that use the KitProg. Table 2-2 lists the prerequisite Cypress
software needed to use the KitProg.

Table 2-1. Development Kits Supported by KitProg

CY8CKIT-042 PSoC 4 Pioneer Kit PSoC 4200

CYB8CKIT-040 PSoC 4000 Pioneer Kit PSoC 4000

CY3280-MBR3 CapSense Evaluation Kit CapSense MBR3
CY8CKIT-042-BLE Bluetooth Low Energy (BLE) Pioneer Kit PSoC 4200 BLE, PRoC BLE
CYB8CKIT-044 PSoC 4 M-Series Pioneer Kit PSoC 4200M

CYB8CKIT-043 PSoC 4 M-Series Prototyping Kit PSoC 4200M

CYB8CKIT-046 PSoC 4 L-Series Pioneer Kit PSoC 4200L

CYB8CKIT-059 PSoC 5LP Prototyping Kit PSoC 5LP

The CY3280-MBR3 CapSense Evaluation Kit features a fixed-function CapSense controller device;
the KitProg on this kit is only used for the USB-I12C bridge functionality. Therefore, except the chapter
6. KitProg USB-12C Bridge on page 27, other chapters of this UG are not applicable to the
CY3280-MBR3 kit.

Table 2-2. Prerequisite Software for KitProg Operation

Programmer PSoC Programmer WWW.Cypress.com/psocprogrammer

Debugger PSoC Creator Www.cypress.com/psoccreator
USB-I2C Bridge Bridge Control Panel (BCP) | Installed along with PSoC Programmer

Any terminal emulator program can be used such as
USB-UART Bridge | Terminal Emulator Program | HyperTerminal (available as part of Microsoft Windows
XP installtaion) or PUTTY (available from www.putty.org)

KitProg User Guide, Doc. # 001-96359 Rev. *I
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The KitProg supports different speeds for communication interfaces. Table 2-3 summarizes the
KitProg operating modes.

Table 2-3. KitProg Operating Modes

KitProg Ecosystem

Programmer 1.6 MHz
USB-I2C Bridge 50, 100, 400, 1000 kHz
USB-UART Bridge 1200, 2400, 4800, 9600, 19200, 38400, 57600, and 115200 |Baud

This document assumes that you know the basics of how to use PSoC Creator™. If you are new to
PSoC Creator, refer to the documentation in the PSoC Creator home page. You can also refer to the

following application notes to get started with PSoC devices:
m Getting Started with PSoC® 4

m Getting Started with PSoC® 4 BLE

m Getting Started with PSoC® 5LP

m Getting Started with CapSense®
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This section explains the method to use the KitProg programmer/debugger integrated onto the
PSoC development kits. The KitProg supports the development kits listed in Table 2-1. This section
uses the PSoC 4 M-Series Pioneer and PSoC 4 M-Series Prototyping Kit as examples.

3.1 Programming Using PSoC Creator

1. Connect the USB cable into the USB connector, J6, as shown in Figure 3-1. If you are connecting
the kit to your PC for the first time, it enumerates as a USB composite device and installs the

required driver software. See the 3.4 KitProg Driver Installation on page 11 section for more
information.

Figure 3-1. Connect USB Cable to J6 (Pioneer Kits)
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Figure 3-2. Connect USB Cable to J6 (Prototyping Kits)
Q-

2. Launch PSoC Creator from Start > All Programs > Cypress > PSoC Creator <version> >
PSoC Creator <version>.

3. Select File > Open > Project/Workspace in PSoC Creator and browse to the desired project.
4. Select Build > Build Project or press [Shift] [F6] to build the project, as shown in Figure 3-3.

Figure 3-3. Build an Example Project

|Ei|e Edit View Project | Build | Debug Tools  Window Help

] T j—j == - N ¥ Build CYACKIT_D44_CapSense_Gestures  Shift+F6 M
Clean CYSCEIT_044_CapSense_Gestures

—
Workspace Explorer (1 project) |£€| Clean and Build CY8CEIT_044_CapSense_Gestures

&

] “Workspace 'CYSCKIT_044

=Pa] Project "CYSCKIT 044,
' TopDesign.cysch
P CYBCKIT_044_CapSe
E}_’) Header Files

Generate Application

I g G |3

Generate Project Datasheet

-

= g
: .ﬂ main.h g \‘\
E}_’II Scurce Files % ~,
: ﬂ main.c =l 2|

5. If there are no errors during build, program the PSoC 4200M device on the kit by choosing
Debug > Program or pressing [Ctrl] [F5], as shown in Figure 3-4.

KitProg User Guide, Doc. # 001-96359 Rev. *I 8



A,
e

CYPRESS

EMBEDDED IN TOMORROW

KitProg Programmer/Debugger

Figure 3-4. Programming Device from PSoC Creator
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3.2 Debugging Using PSoC Creator

To debug the project using PSoC Creator, follow steps 1 to 4 from 3.1 Programming Using PSoC
Creator on page 7. Then, follow these steps:

1. Click the Debug icon or press [F5], as shown in Figure 3-5. Alternately, you can select Debug >
Debug. This programs the device and starts the debugger.

Figure 3-5. Debug Option in PSoC Creator

File Edit View Project Build ' File Edit View Project Build | Debug | JTools Window Help
_;] | : B id &S .l % Windows »
_D. j -—} £l e 3 -}: ﬂ! (R W { 3& s= (%8 Program Ctrl+F5
; " L
¢+ v 33 ‘5 ﬂ :}& P iE Workspace[kplom(ﬁprojects} ~ | 3 Select Debug Target... ]
Workspace Explorer (6 pmjects] v ‘o _Debug E ¥
6] Workspace 'CYSCKIT-044' (6 Proje fu\& Debug without Programming Alt+F5 |
% £l C:) % Emje“ 'g\:ggg-gjj-?cczler' 5 Attach to Running Target... :;
; ' = ! - B roject ' 044 _CapSen: =
L] Workspace 'CYBCKTI' 055 (hheos |5 3] Project ‘CYBCKIT_044_CapSeny || Toggle Breakpoint PoF
& Pa] Project 'CYBCKIT 044 _Acceler] 5 5] project "CYBCKIT044_CapSe e S ;
- Pa] Project 'CY8CKIT_044_CapSent LH] TopDesign.cysch 1 k
i Pa] Project 'CYSCKIT_044_CapSent 23 S < e
EHC) HeaderFi ot
= Pa] Project "CYBCKIT_044_CapSe gt
i ﬂ TDpDes:gn cysch EHED Source Files g 24

aad i = 2

2. When PSoC Creator enters the Debug mode, use the buttons on the toolbar or keyboard short-
cuts to debug your project.

For more details on using the debug features, refer to the PSoC Creator Help. Select Help >
PSoC Creator Help Topics in the PSoC Creator menu. In the PSoC Creator Help window, locate
Using the Debugger section in the Contents tab, as shown in Figure 3-6.
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Figure 3-6. Using the PSoC Creator Debugger
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The PSoC Creator Debugger allows you to observe the run-time behavior of your program and determine the location of semantic errors

w
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Programming Using PSoC Programmer

wnu ran hraak (susnend) execution of vaur o

PSoC Programmer (3.22.2 or later) can be used to program existing .hex files into the kit. To do this,

follow these steps.
1.

PSoC Programmer <version> > PSoC Programmer <version>.

Connect the kit to your PC and open PSoC Programmer from Start > All Programs > Cypress >

Click the File Load button at the top left corner of the window. Browse to the desired .hex file and

click Open. For the PSoC 4 device, the .hex file is located at: <Pr oj ect Di rect ory>\<Proj -

ect

Name. cydsn>\ Cort exMD\ <Conpi | er

<Rel ease>\ <Proj ect Name. hex>.

3.

Nanme and Versi on>\ <Debug> or

Click the KitProg/<serial number> in the Port Selection list to connect the kit to your computer.

Note: If the CY5670 CySmart USB Dongle (BLE Dongle) is used, the device will enumerate as

KitProg/BLE<serial number>.

4. Click the Program button to start programming the kit with the selected file.

Note: If the .hex file does not match the selected device, then PSoC Programmer will display a
device mismatch error and terminate programming. Ensure that you have selected the correct .hex

file.

5. When the programming is completed successfully, indicated by a PASS message on the status
bar, the kit is ready for use. Close PSoC Programmer.

KitProg User Guide, Doc. # 001-96359 Rev. *I
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KitProg Driver Installation
The kits are powered from a computer over the USB interface. It enumerates as a composite device,
as shown in Table 3-1. The USB drivers required for enumeration are part of the kit installer and
should be appropriately installed for its correct operation.
Table 3-1. Enumerated Interfaces
USB Composite Device USB Composite device
USB Input Device USB-I2C bridge, KitProg command interface
KitProg Programmer and debugger
KitProg USB-UART USB-UART bridge, which appears as the COM# port
Note: It is recommended to use KitProg with Windows 7 or later operating systems to ensure proper
operation of KitProg USB-UART COM port. If Windows XP 32-bit is used, ensure that the SP3 is
installed. The Windows XP 64-bit does not support UART debug function.
Figure 3-7. KitProg Driver Installation (appearance may differ depending on the Windows version)
il =
Your device is ready to use
USE Composite Device J’ Ready to use
USE Input Device e‘f'Read}rtD use
KitProg (1.23.3) +f Ready to use
KitProg USB-UART (COM4) +f Ready to use
Updating the KitProg Firmware

The KitProg firmware generally does not require any update. If an update is required, then PSoC
Programmer will display a warning message when the kit is connected to it, as shown in Figure 3-8.

Figure 3-8. KitProg Firmware Update Warning

B WARNING! = 33|

This programmer is currently out of date.

To update the firmware please navigate to the
Lkilities Tab and press the Update Rmware
button

[] Do not show this message again
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Click OK to close the window. On closing the warning window, the Actions and Results window
displays: “Please navigate to the Utilities tab and click the Upgrade Firmware button”, as shown in
Figure 3-9.

To update the KitProg, go to the Utilities tab on PSoC Programmer and click Upgrade Firmware, as
shown in Figure 3-9.

Figure 3-9. Upgrade Firmware in PSoC Programmer

File View Options Help

@ 303 BDODB

Port Selection 4 | Programmerl_

@ KitProg/171D0ES02213400
Click to upgrade connected device's fimware
(Click to erase user specific flash block

TAG |

Device Family
CY8Cdooc-M

Device
CYBCA24TAZI-M485

Actions Results

Please navigate to the Utilities tab and click the Upgrade Firmware
button

Bort Cpened with
Warnings at 10:27:34 LM

Cpening Port at 10:27:32
EM

Connected at 10:27:31 AM KitProg/171DOE3602213400

KitProg wersion Expecting 2.11, but found 2.02.

For Help, press F1 | [ ———

On successful upgrade, the Actions and Results window displays the firmware update message with
the KitProg version, as shown in Figure 3-10.
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Figure 3-10. Firmware Updated in PSoC Programmer
'@ PSol Programmer @M

File  ‘iew  Options  Help

@30:RbR0D

I Port Selection 4p |F'rogrammer| Ltilities | JTAG |

[ @ KitProg/1 CODOT 280114340
Click to upgrade connected device's firmwars
Eraze Block Click to eraze user specific flash block

Device Family
O BC 4wt

Device
CYBC4247AZ-M 485

KitProg firmware version

Actions Results

EitProg &

Firmware Update Finished
at 1:16:45 PH

Succeeded

Verifying... KitProg firmware upgrade message
Upgrading. ..

Initializing...

Firmware Upgrade 3tarted
at 1:16:33 FH

Firwware Upgrade
Requested at 1:16:33 PH

For Help, press Fi e 12551 [IFsvErE N I Eornectsd I
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The KitProg can act as a USB Mass Storage Programmer. The KitProg Programmer and Debugger,
KitProg USB-12C Bridge, and KitProg USB-UART Bridge functionalities are not available in this con-
figuration.

The kits listed in Table 2-1 except CY3280-MBR3 CapSense Evaluation Kit support the USB Mass
Storage Programmer feature.

Visit www.cypress.com/psocprogrammer to download the latest version of the PSoC Programmer.

4.1 Enter or Exit the Mass Storage Programmer Mode

Follow these steps to enter or exit the Mass Storage Programmer mode of KitProg:

1. Connect the kit to the PC. Ensure that the Status LED is on and not blinking. Refer to the section
8.1 KitProg Status LED Indication on page 44 for details on the Status LED indications.

2. Press and hold the reset switch (SW1) of the kit for more than 5 seconds. The Status LED of the
kit turns off when the KitProg changes configurations.

3. Release the reset switch on the kit after Status LED has turned off. The KitProg re-enumerates in
the alternate configuration. For example, the kit enumerates as Mass Storage Programmer if the
previous configuration is KitProg Programmer and Debugger.

Note: The KitProg remains in the selected mode until the user changes the mode manually using
the above steps.

4.2 Programming Using the Mass Storage Programmer

Follow these steps to program the target device using the Mass Storage Programmer:

1. Enter the Mass Storage Programmer mode as explained in the section 4.1 Enter or Exit the Mass
Storage Programmer Mode. The KitProg is visible as a removable disk drive in the file explorer of
the PC, as shown in Figure 4-1.

Figure 4-1. KitProg Emulated as Mass Storage Device
4 Hard Disk Drives (2)

Windows?_05 (C) {m Lenovo_Recovery (Q:)
- a—— - | ;
34.7 GB free of 281 GB @ 5.65 GB free of 156 GB

4 Devices with Eemovable Storage (2)

_ KitProg (E:)
- (d eﬂﬁ CD Drive (D) =

- W 330 KB free of 340 KB
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2. Open the KitProg Drive to view the STATUS.TXT file, as shown in Figure 4-2. Note that the file
extension .TXT is visible for the file, if it is enabled in your PC settings. The STATUS.TXT shows
the current status of the Mass Storage Programmer.

Figure 4-2. STATUS.TXT in the KitProg Drive

= ¥ Computer » KitProg (E:)

- Share with - Burn Mew folder
. Mame Date modified Type Size
ntes -
‘ | STATUSTXT 5/22/2013 3:27 PM Text Docurmnent 1 KB
EA

3. Copy any PSoC 4200M device based project .hex file to the KitProg Drive to begin programming.
Alternately, you can also drag and drop the .hex file on to the drive. The .hex file is available in
the following path:

<Project Directory>\<Project Nane.cydsn>\CortexM\<Conpiler Nanme and
Ver si on>\ <Debug> or <Rel ease>\ <Proj ect Name. hex>

Figure 4-3. Copy the .hex File to KitProg Drive

g (E2)
—————
arn Mew folder
#
Name Date modified Type Size
|| STATUS.TXT 5/22/20133:2T PM  Text Document 1KB
=] CYBCKIT_D44_Accelerometer.hex 5/13/201511:46 AM  HEX File 2B3 KB

-

=/ Copying 1 item (282 KB)

Copying 1 item (282 KB}

from Hex Files (C:\Users\mjt\Desktop'...\Hex Files) to KitProg (E:)
Discovered 1 item (282 KB}...

[— | — |

™ More details

4. The Status LED on the kit blinks during the programming operation. The Status LED continues to
blink for 2 seconds after the programming operation and the KitProg Drive automatically removes
the copied file from the drive. Press F5 in the file explorer to refresh the contents of the drive. This
will display only the STATUS.TXT file in the KitProg Drive.
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5. Open the STATUS.TXT file to view the status of the programming operation, as shown in
Figure 4-4.

Figure 4-4. Status Displayed in the KitProg Drive after Programming

Mame Date modified Type Size

| STATUS.TXT 5/22/20133:27TPM  Text Document 1KB

] STATUSTXT - Notepad AL

File Edit Format View Help

|Cypress KitProg Mass Storage Programmer.

Press and hold the Reset button (SW1) for 5 seconds to exit Mass Storage mode.
Target Device:PSoC 4200M

The HEX file was programmed successfully!
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4.3 Frequently Asked Questions on KitProg Mass Storage
Programmer

1. What are the Cypress kits supported by the KitProg Mass Storage Programmer?

The KitProg Mass Storage Programmer currently supports only CY8CKIT-044 PSoC 4 M-Series
Pioneer Kit.

2. What are the operating systems supported by KitProg Mass Storage Programmer?

The KitProg Mass Storage Programmer works on Microsoft Windows and Apple Mac Operating
Systems. The KitProg Mass Storage Programmer is currently not supported on Linux Operating
System.

3. Why are the contents of F-RAM removed and filled with random values after programming
operation?

The KitProg Mass Storage Programmer uses the on-board F-RAM of the CY8CKIT-044 PSoC 4
M-Series Pioneer Kit to store the contents of the copied .hex file for programming operation. This
is the reason for removal of any stored data.

4. What happens if | copy an incorrect .hex file to the KitProg Drive?

If you copy a PSoC 4200M .hex file with invalid data (incorrect Silicon ID, incorrect Checksum,
and so on), the KitProg Mass Storage Programmer attempts a programming operation and
generates an error indicating which step of the programming operation has failed in the
STATUS.TXT file.

If you copy a .hex file which corresponds to any other device, the KitProg Mass Storage
Programmer does not attempt a programming operation and generates an error indicating that
the copied file is not a valid .hex file in the STATUS.TXT file.

If you copy any other file than specified above and file size does not exceed the KitProg Drive
size, the file will be visible in the KitProg Drive until the KitProg Drive is removed from the PC.
Note that the file is not actually copied to the KitProg Drive. Delete these files before attempting
to program a new .hex file.

5. Why does my Operating System display the pop-up “Disk Not Ejected Properly” after every
programming operation in KitProg Mass Storage Programmer mode?

The KitProg Mass Storage Programmer temporarily ejects 2 seconds after the programming
operation. This can also cause the file explorer window of the KitProg Drive to close after
programming operation in some operating systems.

6. Is it possible to program an external PSoC other than PSoC 4200M using the KitProg Mass
Storage Programmer?
No. The KitProg Mass Storage Programmer supports only PSoC 4200M on the CY8CKIT-044
PSoC 4 M-Series Pioneer Kit.

7. Can | use .hex files generated by any other IDE other than PSoC Creator to program the PSoC
4200M using KitProg Mass Storage Programmer?

Yes. You can also use the .hex file generated for PSoC 4200M by an external IDE such as
Eclipse, IAR, Keil pVision that supports PSoC 4 devices, to program the PSoC 4200M using
KitProg Mass Storage Programmer.

8. Why does the programming time for different files vary?

The KitProg Mass Storage Programmer intelligently programs only the flash rows with non-zero
data. Depending on the contents of your project, the programming time may take up to 20
seconds.
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The KitProg can act as a USB-UART bridge. This feature of the KitProg is useful to send and receive
data between the Cypress device on the kit and the PC. For example, in the PSoC 4 M-Series
Pioneer Kit, the KitProg USB-UART can be used to print debug messages on COM terminal
software running on the PC.

This section explains a method to create a PSoC 4 code example, which communicates with the
COM terminal software using the KitProg USB-UART Bridge. This example uses Windows
HyperTerminal as the COM terminal software. If you have a Windows operating system that does
not have HyperTerminal, use alternate terminal software such as PuTTY.

1. Create a new PSoC 4 project in PSoC Creator, as shown in Figure 5-1. Select a specific location
for your project and name the project as desired. You must select the appropriate device for this
project depending on the kit as provided in Table 2-1. Ensure that the Project template option is
set to Empty schematic. This example uses PSoC 4200M as the target device and PSoC 4 M-
Series Pioneer Kit as the target board.

Figure 5-1. Create New Project in PSoC Creator

Create Project - CYBCA24TAZI-M485 B85 | Create Project - CYBCA247A71-M485 o
Select project type Select project template
Chooss th type of project ~design. library, or workspace Chooss & schematic tempiats o start your design with a kit or example project
Design project
) Target kit 0101) |Code example
2 1L C}vunse ‘from our lbrary of code examples
©) Target module:
@ Target device: | PSoC 4 v][FSuC 4200M v] | T= | Pre popuiated schematic
= Start ith typical MCU functions fike UART, ADC., etc.)

(@) Library project

() Workspace

Emply schematic
Create a ful custom design by adding functionality from the companent catzlog

T e [
Create Project - CYSCA247A7I-M485 |

Create Project

Choose a name and location foryour desian

Create new workspace

Workspace name: | Warkspace01|

Location: C:\Usersi\Documents\PSoC Creator =

Projectname:  Design01

<Bok | B || cance
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2. Drag and drop a UART (SCB mode) Component from the Component Catalog (see Figure 5-2) to
the TopDesign. The Component Catalog is located along the right side of the PSoC Creator
window by default. To configure the UART, double-click or right-click the UART Component and
select Configure, as shown in Figure 5-3.

Figure 5-2. UART Component in Component Catalog

Component Catalog (145 components) -

Search for... a‘ﬁ tl.!i E

2x

| oy S g S oy A ey B g |

- Digital
-5 Display

- Ports and Pins

B System

H-5& Thermal Management

< Cypress | Off-Chip

4 b

il Cypress Compenent Catalog
-ﬁ Analog

-r:_sg CapSense

Ehgg Cemmunicaticns

|24 CAN Controller Macro [v3.0]

g 120

B 125

(] LIN [v3.20]

%] Serial Communication Block [SCB) [v2.0]

G- SMBus/PMBus Slave

| Software Transmit UART [v1.40]

[ b
Sk | LART (SCE mode) [w3.0]

P UART [v2.30]

5l
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Figure 5-3. Open UART Configuration Window

Ctlex.
------- 43 Copy Ctrl+C
& F
X Delete Del
Select All Ctri+A
Zoom »
Shape b
_‘IF' Open Datasheet ...

3. Configure the UART Component as shown in Figure 5-4, Figure 5-5 and Figure 5-6, and then
click OK.

Figure 5-4. UART Configuration Tab Window

Configure 'SCB_P4' @

Name: UART|

Configuration | UART Basic | UART Advanced | Buitn | 4b
) Uncorfigured SCB
(@)%
® EZi2C
© SPI
@ UART

Datasheet ] [ oK H Aoply H Cancel
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Figure 5-5. UART Basic Tab Window

KitProg USB-UART Bridge

[ Clock from teminal
[ Median fiter

[ Enable wakeup from Deep Sleep Mode

" Configure 'sce_pa )
Name: UART
. Configuration  UART Basic | UART Advanced | Built-n qr
Direction:
Baud rate [bps): 9600 - Actual baud rate (bps): 9552
Data bits:
Fas
Stop bits:
Oversampling: 12 =

Figure 5-6. UART Advanced Tab Configuration Window
| S
Name: UART
" Configuration | UART Basic /” UART Advanced | Buit-in | qb
Buffers size Intemupt DMA
RXbuffer size: | 2 @ None ] RX output
TXbuffersize: 2 - " Intemal [T] T output
["] Byte mode _ Bxtemal
[ ok ][ mew Concel |

4. Select P7[0] for UART RX and P7[1] for UART TX in the Pins tab of <Project Name>.cydwr, as
shown in Figure 5-7. The file <Project_Name>.cydwr can be found in the Workspace Explorer
window, which is located along the left side of the PSoC Creator window by default. Double-click
on the file to open it. Note that these are the pins for the USB-UART interface on the PSoC 4 M-
Series Pioneer kit. If you are using a different kit, refer to the respective Kit Guide for the

appropriate pins.
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Figure 5-7. Pin Selection

Alias Mame Port Pin  Lock
. . | P7[0] TCPWMO:line out, SCB3:uart rx, ] [ ]
ART=» — — 7]
\URRT:XHN | oopatiac scl, SCB3:spi mosi M
. . | P7[1] TCPWMO:line cut ccmpl, S5CB3:uart tx,
RRT: ) = - . - Tl |T| ¥
SaL LB S5CB3:i2c sda, SCB3:3pi miso =

5. Place the following code in the main.c file. The code echoes any data received through UART.

Note: The main.c file can be found on the Workspace Explorer window, which is located along the
left side of the PSoC Creator window by default. Double-click on the file to open it.
#i ncl ude <project. h>

int main()
{
uint8 ch;
[* Start SCB UART TX+RX operation */

UART Start();
/[* Transmit String through UART TX Line */

UART Uart Put Stri ng(" CY8CKI T- 044 USB- UART");
for(;;)
{
/* Get received character or zero if nothing has been
recei ved yet */
ch = UART_Uart Get Char () ;
if(Ou !'= ch)

{

/* Send the data through UART. This functions is
bl ocki ng and waits until there is an entry into the TX
FIFO */

UART _Uart Put Char (ch);

6. Build the project by choosing Build > Build [Project Name] or pressing [Shift] [F6]. After the
project is built without errors and warnings, program the project (by choosing Debug > Program)
to the PSoC 4200M using KitProg.

Note: UART RX and UART TX can be routed to any digital pin on PSoC 4 by using the UDB
implementation of the UART Component. In this case, we are using the SCB implementation of
the UART, which routes the pins to one of the specific set of pins supported by the device. This
will vary depending on the PSoC 4 device used.
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To communicate with the PSoC 4200M device from the terminal software, follow this procedure:

1. Connect the USB Mini-B cable to J6. The kit enumerates as a KitProg USB-UART, and is
available in the Device Manager under Ports (COM & LPT). A communication port is assigned
to the KitProg USB-UART, as shown in Figure 5-8.

Figure 5-8. KitProg USB-UART in Device Manager

= Device Manager =NA=h X

File  Action  Wiew Help

e BIE HEI 8 E&D

,.@ Batteries -
,..6 Bluetooth Radios
- 1M Cornputer

> -] CypressUsbConsoleWWindowsDriver
sy Disk drives
- B Display adapters

e DVDSCD-ROM drives

> B Hurnan Interface Devices
o g IDE ATASATAPL contrallers
» 5 Imaging devices
- ¥ Junga Connectivity
s Keyboards
, jf!, Mice and other pointing devices
. Bl Monitars
» - F Metwork adapters
-\ Other devices
4-'7 Ports (COM & LPT)
JT Intel () Active Managerment Technalogy - S0L (COM3)
I T2 KitProg USB-LART (COMILZ) I
- MediaTek PreLoader USEWCOM (Android) (COM29)
- [} Processars
-1 Security Devices
.M SM Driver
> -y Sound, video and game controllers
> & Storage controllers
> (M System dewvices

m

> - g Universal Serial Bus controllers

2. Open HyperTerminal, choose File > New Connection, enter a name for the new connection, and
then click OK as shown in Figure 5-9. For PuTTY, double-click the PuTTY application and select
Serial under Category.

Figure 5-9. Open New Connection
@ PuTTY Configuration &J.‘

HyperTeminal Category:

[=1- Session Options controlling local seral lines
Connection Description @ dh

: Logging
- Teminal

H Keyboard Serial line to connect to COoM12
Bell
Features

- Window Speed (baud) 9600
Appearance

Behaviour
Translation Stop bits 1
Selection

Cdan Earty
(=} Connection How cortrol XOM/¥OFF hd

- Proxy
4 11 3 - Telnet
- Rlogin
- S5H

0K l [ Cancel

Select a seral ine

New Connection Corffigure the serial line

Enter a name and choose an icon for the connection: Data bits 8

Name
USB-UART communication|

lcon:

- )|

Cancel
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3. A new window opens, where the communication port can be selected. In HyperTerminal, select
COMKx (the specific communication port that is assigned to the KitProg USB-UART) in Connect
using and click OK, as shown in Figure 5-10.

In PUTTY, enter the COMx in Serial line to connect to. This example uses COM12.

PuTTY

ﬁ PuTTY Configuration

e EMBEDDED IN TOMORROW
Figure 5-10. Select Communication Port
HyperTerminal
rConnect To @ﬂ—hr

USB-UART communication

Enter details for the phone number that you wantto dial:

Country/region India (91)
Area code: 080
Phone number:
Connectusing: [COM12
[ oK

] [ Cancel ]

-~

4. In HyperTerminal, select Bits per second, Data bits, Parity, Stop bits, and Flow control under

Category:

[=l-Session

| Logging
= Terminal

I Keyboard

=-Window

| Appearance
Behaviour

- Translation

- Selection

- Colours

[=-Connection

Data

Proxy

- Telnet

- Rlogin

[#-SSH

Serial

Options controlling local serial lines

Select a serial line
Seria| line to connectto
Configure the serial line
Speed (baud)

Data bits

Stop bits

Parity

Flow control

Gomi2

9600
8
1

XON/XOFF -

Open

| [ cancel

Port Settings and click OK (see Figure 5-11). Ensure that the settings are identical to the UART
settings configured for the PSoC 4200M device.

In PUTTY, enter the Speed (baud), Data bits, Stop bits, Parity, and Flow control under

Configure t

he serial line.

Figure 5-11. Configure the Communication Port

HyperTerminal

COM12 Properties

X

Port Settings

Bits per second: [9600

Data bits: [8

Parity: [Nune

Stop bits: [1

Elow control: [None

Restore Defaults

ok ||

Cancel | |

Apply l

PuTTY
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ﬁ PUTTY Configuration

Category:

[=-Session

: .. Logging
- Terminal
[ Keyboard
- Bell
Features
=-Window

: Appearance
-~ Behaviour
Translation
- Selection

: Colours
)-Connection

- Data

- Praxy

- Telnet

- Rlogin
#H-88H

Select a serial line

Speed (baud)
Data bits
Stop bits
Parity

Elow control

Serial line to connectto

Options controlling local serial lines

Configure the serial line

e

MNone -
Mone -

comz

o] |

Cancel
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5. Enable Echo typed characters locally under File > Properties > Settings > ASCII Setup to
display the typed characters on HyperTerminal, as shown in Figure 5-12. In PuTTY, select Force
on under Terminal > Line discipline options to display the typed characters on PuTTY, as

shown in Figure 5-12.

Figure 5-12. Enable Echo of Typed Characters in HyperTerminal and PuTTY

HyperTerminal

= )

ASCI Setup

ASCH Sending
Send ling ends with line feeds

[f | Echo typed characters HM:E"]‘_]

Liri chitlay: O

millisecands

Characiers delay: 0 milliseconds

ASCH Recerding
Append ling feeds o incoming ing ends
Earce incoming data o 7-bit ASCI
+ | Wrap lines that excead lerminal width

Cancel

PuTTY

£ euTTY Configuration

Catigory
Samn

QRN
maytacmed

Ball
Foatans

Window
L
Blahaeu
Translatsn
Dalechon
Colowrs

Connecion
Ditn
Praxy
Taboat
Figgn

3] 55H
Sanal

(phons conipoling ha lermnal smulaton
Sl varo wimnal oplons
o | Aute piap Soce maaly on
DEC Qngn Mods mskally on
Impleit CF in wvory LF
imphet LE in avary CR
o | Lt backgeound colow 10 arase scisen
Enable blskang bax
Argwertack i “E
PuTTY

Line discoplne opions
Loca echo

Bavites 1o sand ANS panted outpul ia
o (pringng deabied) -

Carcel

6. In PuTTY, click Session and select Serial under Connection type. Serial line shows the
communication port (COM12) and Speed shows the baud rate selected. Click Open to start the
communication, as shown in Figure 5-13.

Figure 5-13. Opening Port in PuTTY

]

F
ﬁ PuTTY Configuration
Category:
= l Session | Basic options for your PuTTY session
D TE"" Paglgjing Specify the destination you want to connect to
- Terminal o
. Keyboard Serial line Speed
COoM2 9600
Bell
- Features Connection type:
=)~ Window ) Raw () Telnet (O) Rlogin (©) SSH  |@ Seral
Appea@nce Load, save or delete a stored session
- Behaviour
... Translation Saved Sessions
- Selection
- Colours :
Default Settings
[=)- Connection [ﬂ]
- Prosey
- Rlogin
- 55H
 Seridl Close window on ext:
) Mways ) MNever @ Only on clean exit
About I Open I ’ Cancel
b
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7. The COM terminal software displays both the typed data and the echoed data from the PSoC
4200M UART, as shown in Figure 5-14.

Figure 5-14. Data Displayed on HyperTerminal and PuTTY

E ' USB-UART Communication - HyperTerminal
File Edit View Call Transfer Help
=2 5 DB

£B COMI2 - PuTTY
Yy

CYSCKIT-044 USB-UART PPSSooCC

Connected 0:00:44 Auto detect  Auto detect CAPS  NUM
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The KitProg serves as a USB-I2C bridge that can be used to communicate with the USB-I2C soft-
ware running on the PC. For example, the KitProg USB-I2C Bridge can be used to tune the
CapSense Component on a PSoC device. This feature is applicable to all kits listed in Table 2-1.
This section uses the PSoC 4 M-Series Pioneer Kit as an example to demonstrate the KitProg USB-
I2C Bridge functionality. The following steps describe how to use the USB-I12C Bridge, which can
communicate between the Bridge Control Panel (BCP) software and the PSoC 4200M device.

Note: For information on how to use the KitProg USB-I12C Bridge to tune the CapSense Component,

refer to Section 5.2.2 Manual Tuning Process in AN85951 - PSoC 4 CapSense Design Guide.

1. Create a new PSoC 4 project in PSoC Creator, as shown in Figure 6-1. Select a specific location
for your project and name the project as desired. You must select the appropriate device for this
project depending on the kit, as provided in Table 2-1. Ensure that the option Project template is
set to Empty schematic. This example uses PSoC 4200M as the target device.

Figure 6-1. Create New Project in PSoC Creator

Create Project - CYBC4247AZI-M485 93 | create Project - CY8C4247A71-M485 [

Select project template
Choose a schematic template or start your design with 3 kit or example projsct

Select project type
Choose the type of project - design, library, or workspace.

Design project
) Target kit u101) |Code example
o C}\nnsaimm ourlibrary of code examples
) Target module
© Target device: [PSoC4 | [PSoC 4200M -] | 7= Pre-popuiated schematic
=) Start with typical MCU functions ke UART. ADC. etc.).

(@ Librery project

©) Workspacs

Empty schematic
Create = ful custem design by adding functionaly from the companznt catalog

=] T e [
Create Project - CYBCA247AZ1-M485 P )

Create Project

Choose a name and location for your design.

Create new workspace

Workspace name:  Workspace01]

Location C:\Users:\Documents\PSoC Creator ()

Projectname:  Design01

Back || Fmsh | [ P
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2. Drag and drop an EZI2C Slave (SCB mode) Component from the Component Catalog (see
Figure 6-2) to the TopDesign. The Component Catalog is located along the right side of the PSoC
Creator window by default. To configure the EZI2C Slave Component, double-click or right-click
the EZI2C Slave Component and select Configure, as shown in Figure 6-3.

Figure 6-2. EZI2C Slave Component in Component Catalog
|Cummt€aliiug (145 components) - 1 K|

Search for... nﬁ U.JI @

Cvpressi Off-Chip q B

-1<_>§ Analog

ﬂ Cap5ense

E}Qg Communications

@ CAM Controller Macro [v3.0]
EHgg [2C

-8} EZI2C Slave (SCB mode) [v3.0]
-2} 12€ (5CB mode) [v3.0]

By 125

-] LIN [w3.20]

-] serial Communication Block (SCB) [v3.0]
B SMBus/PMBus Slave

-[¢] Software Transmit UART [v1.30]
Bl SPI

|2 UART (SCB mode) [v3.0]

- E UART [v2.30]

FH-feg Digital

@ Display

[#-& Ports and Fins

A

H

+- System
+-% Thermal Management

Figure 6-3. Open EZI2C Slave Configuration Window

cut Cirl+x

&

53] Copy Ctrl+C
I3 Paste Crl+
# | Delete Del
Select All Ctrl+A

Zoom 4

Shape 4

Configure...
Disable

=1 OpenDatasheet...

Find Example Project...

Open Component Web Page
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3. Configure the EZI2C Slave Component as shown in Figure 6-4 and Figure 6-5, and then click

OK.
Figure 6-4. Configuration Tab

Configure 'SCB_P4'

? i |

Name: EZI2C_1

" Configuration |© EZI2C Basic

EZI2C Advanced

Built-in

4Pk

) Uncorfigured SCB
® 12C

@ EZI2C

@ SPI

() UART
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Figure 6-5. EZI2C Slave Basic and Advanced Tabs\
[ Configure 'sCB_pa' =

MName: EZI2C_1

" Configuration /" EZ12C Basic | EZI2C Advanced | Buitin qp
Data rate (kbps): - Actual data rate (kbps): 100

[ Clock from teminal
Clock stretching

[T] Byte mode
Number of addresses:
Primary slave address (7-bits): 08

(09
Sub-address size (bits):

[] Enable wakeup from Deep Sleep Mode

-

.
Configure 'SCB_P4" [ 2 S

Name: EZI2C_1

Configuration |~ EZI2C Basic .~ EZI2C Advanced | Built-n q I
Slew rate: Fast hd
33
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4. Select pin P4[0] for the I12C SCL and pin P4[1] for the I12C SDA in the Pins tab of
<Project_Name>.cydwr, as shown in Figure 6-6. The <Project_Name>.cydwr file is available in
the Workspace Explorer window, which is located along the left side of the PSoC Creator window
by default. Double-click on the file to open it. Note that these are the pins for the USB-I12C inter-
face on the PSoC 4 M-Series Pioneer kit. If you are using a different kit, refer to the respective Kit
Guide for the appropriate pins.

Figure 6-6. Pin Selection

Alias Mame Port Fin Lock

P4[0] SCBO:uart_rx, CRANO:can_rx, 7
SCE0:iZc scl, SCBO:spi mosi M il
P4[1] 5CBO:uart tx, CANO:can_tx, -

SCRO:i2c sda, SCBO:spi miso M

VEZIZC 1:3clh

VEEI2C_1:=sadah

5. Place the following code in the main.c file. The code will enable the PSoC 4200M device with the
BCP application using the EZI2C Slave interface.

Note: The main.c file can be found on the Workspace Explorer window, which is located along the
left side of the PSoC Creator window by default. Double-click on the file to open it.
#i ncl ude <project.h>

#defi ne BUF_SI ZE Ox0A
#defi ne READ WRI TE_SI ZE 0x05

int main()
{
/* 12C Read/ Wite Buffer. */

ui nt 8 i 2cBuf f er [ BUF_SI ZE] ;
Cyd obal | nt Enabl g;
EZI2C 1_Start();

/* This APl sets the buffer and address boundary to which the external
* master can comunicate. In this exanple, external naster can read
* fromand wite to the first 5 bytes of the i2cBuffer and read bytes
* fromall the 10 bytes of the i2cBuffer array. */

EZI 2C_1_Ez| 2CSet Buf f er 1( BUF_SI ZE, READ WRI TE_SI ZE, i2cBuffer);

for(;;)
{
}
}
6. Build the project by choosing Build > Build Project or pressing [Shift] [F6]. After the project is

built without errors and warnings, program ([Ctrl] [F5]) this project onto the PSoC 4200M using
KitProg.

7. Open the BCP from Start > All Programs > Cypress > Bridge Control Panel <version> >
Bridge Control Panel <version>.
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8. Select KitProg/<serial number> under Connected 12C/SPI/RX8 Ports, as shown in Figure 6-7.
Figure 6-7. Connecting to KitProg in BCP

r
a; Bridge Control Panel E@g
File  Editor Chart Execute Tools Help
FEE IR CE EERE
Editor | Chart | Table | File
1 3
Select Port in the PortList, then try to connect -
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§ 3
Connected [2C/5PI/RXE Ports: 3 -
- : - mizod
[@Heset ][_::List ]EﬁSend ] ::d all strings: [ ; F‘ '0F 1B0E3602213400 +5.0 © I
= eat count: Hllcomio +3.3 SP
Stop at il o -
(oo | repeat | Bloste | 77 2t e

9. Open Protocol Configuration from the Tools menu and select the appropriate 12C Speed, as
shown in Figure 6-8. Ensure that the 12C speed is the same as the one configured in the EZI2C

Slave Component. Click OK to close the window.

Figure 6-8. Opening Protocol Configuration Window in BCP

R Bridge Control Panel

File  Editor Chart Execute | Tools | Help
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Edtor |Chart | Table | Fie | I2C Bootloader "
|
Protocol Configuration @
[sPL_ [T {[Rxa uART)|
12C Speed

0 1MHz ) 400kHz @ 100kHz ) 50kHz
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10.From the BCP, transfer 5 bytes of data to the 12C device with slave address 0x08. The EZI2C
Slave requires an additional parameter to be sent from the BCP to set the offset address from/to
where the data bytes are read/written. Type the command shown in Figure 6-9 and press [Enter]

or click the Se

after a byte indicates that the transaction was successful, and a

was a failure.

nd button in the BCP. The log shows whether the transaction was successful. A “+”
“-” indicates that the transaction

Figure 6-9. Enter Commands in BCP
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11.From the BCP, read 5 bytes of data from the 12C slave device with slave address 0x08. The log
shows if the transaction was successful, as shown in Figure 6-10.
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Figure 6-10. Read Data Bytes from BCP
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Note: You can add additional lines of commands by pressing [Ctrl] [Enter]. To execute any line,
click on that line and press [Enter] or click the Send button.

Refer to Help > Help Contents in the BCP or press [F1] for more information on the 12C commands.
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The KitProg is implemented using a PSoC 5LP device. You can also use the PSoC 5LP as a mixed-
signal system-on-chip device to build your own custom projects. For example, the PSoC 5LP on the
kit can be reprogrammed to act as a function generator for the kit. Refer to the application note

AN69133 - PSoC® 3 / PSoC 5LP Easy Waveform Generation with the WaveDAC8 Component for
details on how to create waveforms using a PSoC 5LP device.

Two types of projects can be created for a PSoC 5LP that runs KitProg: Bootloadable and Normal.
Bootloadable projects can be programmed into the PSoC 5LP using the USB connection from a PC
without any specialized hardware. To program Normal projects, you will require a MiniProg3. You
also need to populate the PSoC 5LP programming header on the development kit. For the PSoC 4
M-Series Pioneer Kit, this header is marked J5. See the respective kit guide for more information on
the PSoC 5LP programming header. Jump to the section Building a Normal Project for PSoC
5LP chapter on page 42, if you want to create a normal project for PSoC 5LP.

To learn more about the bootloading concept, refer to the application note AN73854 - PSoC® 3,
PSoC 4, and PSoC 5LP Introduction to Bootloaders.

Note: The CY3280-MBR3 CapSense Evaluation Kit does not have a provision to populate the
programming header for PSoC 5LP.

The following sections provide step by step directions for building a Bootloadable and a Normal
project for PSoC 5LP.

71 Building a Bootloadable Project for PSoC 5LP

All bootloadable applications developed for the PSoC 5LP should be based on the bootloader .hex
file, which is programmed onto the kit. Therefore, you will need to provide the location of the
bootloader .hex file inside the bootloadable project.

The bootloader .hex file is included in the kit installer directory in the following path, as shown in
Figure 7-1:

<Install _Directory>\<Kit_ Nanme>\<version>\Fi rnnar e\ Programer\Ki t Prog_Boot
| oader

Figure 7-1. KitProg Bootloader Hex File Location

= | B |-
@-\J'ﬂ .« 10 » Firmware » Programmer » KitProg_Bootloader v| p.. 0|
Organize » Include in library « Share with + Burn Mew folder =l | Ef}l
¢ Favorites = Mame : Date modified Type
B Desktop E || KitProg_Bootloader.elf 2/27/2014 %:57 PM ELF File
& Downloads l KitProg_Bootloader.hex 2/27/2014 2:57 PM  HEX File]
'\ Recent Places
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To build a bootloadable application for the PSoC 5LP, follow this procedure:

1. In PSoC Creator, choose New > Project and click the PSoC 5LP Design; select Launch Device
Selector from the drop-down list for Device to bring up the Select PSoC 5LP Device window
and select CY8C5868LTI-LP039, as shown in Figure 7-3. Click OK.

Note: If you have not set the Application Type as Bootloadable in the New Project window under
the Advanced section (in PSoC Creator 3.1 or earlier), you can change it in the existing project by
selecting Project > Build Settings and click the <Project Name> > Application Type >
Bootloadable. Beginning with PSoC Creator 3.2, the Application Type option is removed from the
New Project window and the Build Settings menu. PSoC Creator 3.2 automatically recognizes the
application type from the TopDesign schematic.

Figure 7-2. Open New Project in PSoC Creator
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Figure 7-3. Select Device in PSoC Creator
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2. Navigate to the Schematic view and drag and drop a Bootloadable Component (see Figure 7-4)
on the TopDesign.

Figure 7-4. Bootloadable Component in Component Catalog
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KitProg User Guide, Doc. # 001-96359 Rev. *I 37



o CYPRESS

g EMBEDDED IN TOMORROW

Developing Applications for PSoC 5LP

3. Set the dependency of the Bootloadable Component by selecting the Dependencies tab in the
configuration window and clicking the Browse button, as shown in Figure 7-5. Select the
KitProg_Bootloader.hex (see Figure 7-6) and click Open.

Note: The KitProg_Bootloader.elf is selected automatically if it is also available with the same name
in the same path. Ensure that both .hex and .elf file exist in the same folder by the same name.

Figure 7-5. Configuration Window of Bootloadable Component

-
Configure 'Bootloadable’
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Name: Bootloadable_1
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~elf, “.out, "2, or other.

Bootloader HEX file:

Boctloadable projects require a reference to the associated Bootloader project’s HEX and ELF
files. The HEX files extension is * hex. The ELF files extension depends on IDE and can be

Bootloader ELF file:
]
Figure 7-6. Select KitProg Bootloader Hex File
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4. In the General tab, check the Manual application image placement checkbox and set the
Placement address as ‘0x00002800’, as shown in Figure 7-7.

Figure 7-7. Bootloadable Component-General Tab
rConﬁgurE'Baotloadable' l ? &1

MName: Bootloadable_1

" General |" Dependencies |~ Built-in 4

Application wersion: (0000
Application |1D: (0000

Application custom 1D:  Ge00000000

Manual application image placement
Placement address:  (00002300]

e rr———

5. Develop your custom project.

6. Ensure that the <project name>.cydwr System settings of the Bootloadable project and the
KitProg_Bootloader project are the same. Figure 7-8 shows the KitProg_Bootloader.cydwr
System settings.

Figure 7-8. KitProg Bootloader System Settings
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7. Build the project in PSoC Creator by choosing Build > Build Project or pressing [Shift] [F6].

8. To program the project onto the PSoC 5LP device, open the Bootloader Host tool, which is
available in PSoC Creator. Choose Tools > Bootloader Host, as shown in Figure 7-9.

Figure 7-9. Open Bootloader Host Tool i

n PSoC Creator
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n

Datapath Config Toaol...

DMA Wizard... " Start Page | TopDesi

Component Tuners b | Pecet F_xpand
%] Bootloader Host...

ion

Options... Configuraticn

9. Keep the reset switch (SW1) pressed and connect the kit to the computer. If the switch is pressed

for more than 100 ms, the PSoC 5LP

enters the bootloader.

10.1n the Bootloader Host tool, click Filters and add a filter to identify the USB device. Ensure that
the check box for Show USB Devices is enabled. Set VID as 0x04B4, PID as 0xF13B, and click

OK, as shown in Figure 7-10.

Figure 7-10. Port Filters Tab in Bootloader Host Tool
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11.1n the Bootloader Host tool, click the Open File button (Figure 7-11) to browse to the location of

the bootloadable file (*.cyacd), as shown in Figure 7-12. This file is present in the project
directory.

Figure 7-11. Open Bootloadable File in Bootloader Host Tool
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Figure 7-12. Select Bootloadable .cyacd File from Bootloader Host Tool
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12.Select the USB Human Interface Device in the Ports list and click the Program button
(Figure 7-11) in the Bootloader Host tool to program the device.

13.If the bootload is successful, the log displays “Programming Finished Successfully”; otherwise, it
displays “Failed” and a reason for the failure.

Notes:

m The PSoC 5LP pins are connected to the PSoC 5LP GPIO header. These pins are selected to
support high-performance analog and digital projects. See A.1 Pin Assignment Tables for pin
information.

m Take care when allocating the PSoC 5LP pins for custom applications. For example, P3[2]-P3[3]
are dedicated for programming the PSoC 4200M in CY8CKIT-044. Refer to the respective kit
schematics before allocating the pins.

m When a custom bootloadable project is programmed onto the PSoC 5LP, the initial capability of
the PSoC 5LP to act as a programmer, USB-UART bridge, or USB-I2C bridge is not available. To
recover this functionality, bootload the KitProg file back into the PSoC 5LP. The file is available in
the kit installation directory at:
<Install _Directory>\<Kit_Nane>\<versi on>\Fi r mnar e\ Progr anmer\ Ki t Pr og\ Ki
t Prog. cyacd

m The status LED does not function unless it is used by the custom project.

For additional information on bootloaders, refer to the AN73503 - USB HID Bootloader for PSoC 3
and PSoC 5LP.

Building a Normal Project for PSoC 5LP

A normal project is a completely new project created for the PSoC 5LP device on the PSoC 4 M-
Series Pioneer board. Here the entire flash of the PSoC 5LP is programmed, overwriting all boot-
loader and programming code. To recover the programmer, USB-UART bridge or USB-12C bridge
functionality, reprogram the PSoC 5LP device with the factory-set KitProg.hex file, which is shipped
with the kit installer.

Note: You cannot program a normal PSoC 5LP project into the KitProg's PSoC 5LP device in proto-
typing kits such as CY8CKIT-059 and CY8CKIT-043. The PSoC 5LP device present in the KitProg of
the prototyping kits supports programming through bootloading only.

The KitProg.hex file is available at the following location:
<Install _Directory>\<Nane_of the_ Kit>\<version>\Firmare\Programer\Kit-
Prog\ Ki t Prog. hex

This advanced functionality requires a MiniProg3 programmer, which is not included with this kit. The
MiniProg3 can be purchased from www.cypress.com/go/CY8CKIT-002. In addition, the 10-pin PSoC
5LP programming header (PSoC 5LP PROG) on the kit needs to be populated (refer to the kit’s Bill
of Materials for ordering the part) to connect the MiniProg3 for programming and debugging the
PSoC 5LP device.
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To build a normal project for the PSoC 5LP, follow these steps:

1.

In PSoC Creator, choose New > Project and click the PSoC 5LP Design; select Device as
CY8C5868LTI-LP039 (see Figure 7-13), and then click OK.

Figure 7-13. Create New Project in PSoC Creator

Al
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Select project type Select project template
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© Tergetdevice: [PSoC5LP | [Last used: CYBC5B6BLTILPO39 ~] | Empty schematic
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Lbrary project
Workspace
. [ e o
Create Project - CYBC5868LTI-LP039 P |
Create Project
Choose a name and location for your design.
Create new workspace
Workspace name:  Workspace01
Location: C:\lsers\Documerts \PSaC -+~ ]

Froject name: Design1

< Back J" Enish H Cancsl

Develop your custom project.
Build the project in PSoC Creator by choosing Build > Build Project or pressing [Shift] [F6].
Connect the 10-pin connector of MiniProg3 to the onboard PSoC 5LP PROG header.

To program the PSoC 5LP with PSoC Creator, choose Debug > Program or press [Ctrl] [F5]. If
the Select Debug Target window appears and shows MiniProg3 and the selected device in the
project under it (CY8C5868LTI-LP039), click on the device and click Connect to program.

Notes:
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The 10-pin PSoC 5LP programming header is not populated.

The PSoC 5LP pins are brought to the PSoC 5LP GPIO header. These pins are selected to
support high-performance analog and digital projects. See A.1 Pin Assignment Tables for pin
information.

Take care when allocating the PSoC 5LP pins for custom applications. For example, P3[2]-P3[3]
are dedicated for programming the PSoC 4200M in CY8CKIT-044. Refer to the respective kit
schematics before allocating the pins.

When a normal project is programmed onto the PSoC 5LP, the initial capability of the PSoC 5LP
to act as a programmer, USB-UART bridge, or USB-I12C bridge is not available.

The status LED does not function unless it is used by the custom project.
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This section explains the methods to troubleshoot the KitProg and recover the KitProg firmware if you modified it.

8.1 KitProg Status LED Indication

The KitProg Status LED on the development kit indicates the status of the KitProg operation using different blink rates.
Table 8-1 shows the KitProg LED indication and the corresponding status of the KitProg.

Table 8-1. Meaning of KitProg LED Indications

LED blinks fast: LED starts blinking at power up, Bootload the KitProg.cyacd file: In PSoC

_ if bootloadable fils is corrupt Programmer, connect to the kit, go to the Utilities
Frequency = 4.00 Hz Pt tab, and press the Upgrade Firmware button.

Release the Reset button and re-plug the kit if you
entered this mode by mistake. If the mode entry was
intentional, bootload the new .cyacd file using the

LED blinks slow: Entered Bootloader mode by

holding the Reset button during
Frequency = 0.67 Hz

kit power-up. Bootloader Host tool available in PSoC Creator.
In PSoC Programmer, watch the log window for

SWD or I12C operation is in status messages for SWD operations. In the BCP,

progress. the LED blinks on 12C command requests.

LED blinks very fast:

Frequency = 15.0 Hz The Kit's COM port connect / In BCP or any other serial port terminal program,
’ disconnect event (only one distinguish the kit's COM port number by the
blink). blinking LED when the port is connected or
disconnected.
USB enumeration successful. PSoC Creator, PSoC Programmer, BCP, and any
LED is ON Kit is in the idle state waiting for | serial port terminal program can use the kit
commands. functions.

This means that the USB enumeration was
unsuccessful. This may happen if the kit is not
LED is OFF Power LED is ON powered from the USB host. Verify the USB cable
and check if PSoC Programmer is installed on the
PC.

Note: The Bridge Control Panel software cannot connect to the KitProg, if the KitProg firmware
version is outdated. Refer to Updating the KitProg Firmware on how to update the KitProg firmware.

Note: The programming/debugging function and USB-I12C bridge function of the KitProg are
mutually exclusive functions and cannot be used together. As a result, in order to use one function,
the other function should be disconnected. For instance, in order to program the device while using
USB-I2C bridge in BCP, either close BCP or disconnect the USB-12C bridge in BCP. The USB-UART
bridge function of the KitProg, however, can run in parallel to both programming/debugging and
USB-I12C bridge functions.
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8.2 PSoC 5LP Factory Program Restore Instructions

PSoC 5LP is Programmed with a Bootloadable Application

Reprogramming or bootloading the PSoC 5LP device with a new flash image will overwrite the Kit-
Prog and forfeit the ability to use the PSoC 5LP device as a programmer/debugger for the kit. If the
PSoC 5LP is programmed with a bootloadable application, restore the KitProg by using one of the
following two methods:

m Restore PSoC 5LP Factory Program Using PSoC Programmer

m Restore PSoC 5LP Factory Program Using Bootloader Host Tool

Note: This method cannot be used to recover the KitProg if the PSoC 5LP was reprogrammed using
a MiniProg3. Jump to section Restore PSoC 5LP using MiniProg3 if you want to recover the KitProg

functionality using a MiniProg3.

Restore PSoC 5LP Factory Program Using PSoC Programmer

1. Launch PSoC Programmer from Start > Cypress > PSoC Programmer <version> > PSoC
Programmer <version>.

Configure the PSoC 4 M-Series Pioneer Kit in bootloader mode. To do this, while pressing the
reset button (SW1 for pioneer kits and SW3 for prototyping kits), connect the PSoC 4 M-Series
Pioneer Kit to the computer using the included USB cable (USB Standard-A to Mini-B). This puts
the PSoC 5LP into bootloader mode, which is indicated by the blinking green status LED.

The following message appears in the PSoC Programmer Results window (see Figure 8-1):
“KitProg Bootloader device is detected”.

8.2.1.1

2.

Figure 8-1. PSoC Programmer Results Window

'3 PSoC Programmer

File View Options Help
g----ﬂ\
Port Selection b4 | Programmer | Utilities | JTAG |
Programming Parameters
File Path: C:\Program Files\Cypress\CYBCKIT-049-4 1x01.0\Firmware\SCE_Bootloader\Dependencies\UJART_Bootloas
Pl il [3
Programmer:
Programming Mode: Reset Power Cycle Power Detect
Verification: On Off Connector: Sp ) 10p
AutoDetection: C 1B M
Device Family autolletection: 2) On O Clock Speed: | 1.6 MHz
|CYBCM = | Programmer Characteristics Status
Protocol; JTAG SWD 198P 12 Execution Time:
i B Status: —
Device Voltage: ) 50V ©) 33V (0 25V () 18V | erodls
[cvaca125ax1483 -] Voltage: MA
Actions Fesults =
Select Port in the PortlList, then try to connect
Connected at 4:52:19 PHM EitProg bootloader device iz detected
Please close all ports, then navigate to the Utilities tab and click the Upgrade
Firmware button to recover Bridge

4. Switch to the Utilities tab in PSoC Programmer and click the Upgrade Firmware button, as
shown in Figure 8-2. Unplug all other PSoC programmers (such as MiniProg3 and DVKProg)
from the PC prior to clicking the Upgrade Firmware button.
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Figure 8-2. Upgrade Firmware

Troubleshooting the KitProg

B PSoC Programmer
File View Options Help

@ s G

Port Selection b4 | Programmer| Utilties | JTag |

(B8 BoR =8

[t Femwme. ]| ciscto g coneciod vt s

Erase Block Click to erase user specific flash block

Device Family

Device

Actions Resuks

button to recover Bridge

Connected at 1:38:46 PM KitProg bootloader device i= detected

Pleasze close all ports, then navigate to the Utilities tab and click the Upgrade Firmware

For Help, press F1

5. After programming is completed, the message “Firmware Update Finished at <time>” appears,
and PASS message is indicated on the status bar, as shown in Figure 8-3.

Figure 8-3. Firmware Update Completed

[ [ )

ﬁﬁ nbcpmg@EE:ﬁ.in---i;;;;;IIiiill---ililllii;;iiiillt;

File View Options Help
@3 @en LB

| Pot Sefecton 4¥ | Programmer, Utlities | JTAG |

[ @ KitProg/17100E3602213401

lll!ﬁ!!ﬁiillll Click to erase user speciic flash block

Device Family
CYBChoo:-M -

Device
CYBCA247AZI-M485 >

lliﬂﬁi!ﬁiii!ll Click to upgrade connected device's fimware

Actions Results
| XicProg vVersion 2.11]|

Firmware Update Finished
at 10:30:40 AM

Succeeded
Verifying...
Upgrading...
Initializing...

Firmware Upgrade Starte
at 10:30:30 AM

Firmware Upgrade
Requested at 10:30:30 AM

utton

Port (nened with

Please navigate to the Utilities tab and click the Upgrade Firmware

For Help, press F1

6. The factory program is now successfully restored on the PSoC 5LP. It can be used as the

programmer/debugger for the PSoC 4200M device.
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8.2.1.2 Restore PSoC 5LP Factory Program Using Bootloader Host Tool

1. Launch the Bootloader Host tool from Start > Cypress > PSoC Creator <version> >
Bootloader Host.

2. Using the File > Open menu, load the KitProg.cyacd file, which is installed with the kit software,
as shown in Figure 8-4. The default location for this file is:

<Install _Directory>\<Kit_Name>\<version>\Fi rmivare\ Programmer\Kit Prog\KitP

r og. cyacd

Figure 8-4. Load KitProg .cyacd File

' Bootloader Host EI@

Eile  Actions  Help

I—l'\

G\ Program Files (B6]\Cypress'\C'YBCKIT-042-BLE Kit'\1.0"Fimware"\Programmer'Kit P Prog.cya D
Ports: Port Configuration :] Port Information

Log:
Ready
| Open =z
S~
Uu | <« Firmware » Programmer » KitProg - |¢,|| Search KitProg ,O|
Organize New folder = -F @:]
=
e = MName Date modifi
< Favorites
& Downloads |_| KitProg.cyacd 6/2/2014 50
=, Recent Places
B Desktop
“ Librari |3 Mo preview
. Libraries !
available.
M Computer
£, Windows7_05 (C) |
%3 Lenovo_Recovery (Q:) =
- 4 T - 3
File name: KitProg.cyacd - IEootIoader Files (*.cyacd) - ‘
[ Open |v] I Cancel I
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3. Configure the PSoC 4 M-Series Pioneer Kit in bootloader mode. To do this, while holding down

the reset button (SW1 for pioneer kits and SW3 for prototyping kits), connect the PSoC 4 M-

Series Pioneer Kit to the PC using the included USB cable (USB Standard-A to Mini-B). This puts

the PSoC 5LP into bootloader mode, which is indicated by the blinking green status LED.

4. In the Bootloader Host tool, set the filters for the USB devices with VID: 04B4 and PID: F13B.
The USB Human Interface Device port appears in the Ports list. Click the port to select it, as

shown in Figure 8-5.

Figure 8-5. Select USB Human Interface Device

-| Bootloader Host

File  Actions Help
-3 A
ar & Eb=0%

Ports: | Fiters.. || Por Corfiguration uss

|F' (173 T s ;Jé:lncurrhgulalun necessary for this

Log:

E=H ECH ™™

File:  C:\Program Files {<86)\Cypress\CYBCKIT-042-BLE Kit\1.0%Firmware\Programmer'Kit Prog\KitProg.cyacd

Port Informa
VID: 04B4
PID: F13B

IDT :48:37 PM - Selected device: USE Human Interface Device (04B4_F13B) I
T

5. Click the Program button (or choose Actions > Program) to restore the factory program by

bootloading it onto the PSoC 5LP.

6. After programming is completed, the message “Programming Finished Successfully” appears, as

shown in Figure 8-6.

Figure 8-6. Programming Finished Successfully

| Bootloader Host
Eile  Actions Help

Ports Port Corfiguration

Log:

File:  C\Program Files (B6)\Cypress\CYBCKIT-042-BLE Kit\1 D\Fimware\Programmer'Kit Prog" Kt Prog cyacd

Port Information

=8 el =8

01:48:37 PM - Selected device: USB Human Interface Device (04B4_F13B)
02:02:04 PM - Programming Started

02:02:08 PM - Programming Finished Successfully

Programming completed in 4367ms

Ready

7. The factory KitProg program is now successfully restored on the PSoC 5LP.
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8.2.2 Restore PSoC 5LP using MiniProg3

This section explains the method to reprogram the PSoC 5LP using a MiniProg3 to recover the
KitProg functionality. This method must be used to recover the KitProg if the PSoC 5LP was
completely reprogrammed.

Note: Programming of KitProg through MiniProg3 is not possible in prototyping kits (CY8CKIT-043
and CY8CKIT-059).

1. Launch PSoC Programmer from Start > Cypress > PSoC Programmer <version> > PSoC
Programmer <version>.

2. Connect the MiniProg3 to the PC. Connect the 10-pin connector of MiniProg3 to the onboard
PSoC 5LP programming header.

Note: This header is not populated by default. You will need to populate this header in order to

connect a MiniProg3.

3. Select the MiniProg3 from the Port Selection list in the PSoC Programmer on your PC.

4. Using the File > Open menu or using the File Load icon, load the KitProg.hex file, which is
installed with the kit software, as shown in Figure 8-7. The default location for this file is:

<l nstall

Pat h>\ <Nane_of the_ Kit>\<version>\Firnmnare\Programer\KitProg\KitProg. hex

5. Select the Power Cycle option for Programming Mode, 10p (10 pin) option for Connector, and
the SWD option for Protocol.

6. Click the Program button or File > Program to program the PSoC 5LP device.
7. After programming is complete, the “Program Finished at <time>”" message is displayed.

Figure 8-7. Select the KitProg.hex File to Program the PSoC 5LP

¥ psocC Programmer = |[=2][=®
File View Options Help
~ K T
[@ 3 @2 B D
‘ Port Selection 4lp | Programmer Ulilitiesg JTAG
@ MiniProg3/1223DD0003BC Programming Parameters |
File Path:
@ Open HEX file (w23
@v}‘ <« 1.0 » Firmware » Programmer » KitProg v[‘T'I Search KitProg 2|
Organize » New folder = | 9
Device| -
<. Recent Places & Name Date modified T
Workshops
e | | KitProg.hex 11/10/2014 9:56 AM —I
Device| PSoC 4A-Training
CY7C Mass Storage For KitProg
Action
Suced 4 Libraries
to “<| Documents
ind ’ Mo pre labl
Minil o Music F .
at 7 5
=/ Pictures
Cpen] =
M B videos A
Devil e Computer
cY7c T
7112 = Windows?_0S (C:)
Bevi .—. CD Drive (D2) < g = <
CY7C
Aoty File name: KitProg.hex ~ | HEXfiles (*hex) -
T:12 y
I‘ Open ‘I | Cancel |
For Help, press,2. .~~~ b |  Powered
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8.3 Leakage Current Reduction on Target MCU through SWD Lines

A current bounce in the range of several hundred microamps may be observed on a target in low
power modes, because the SWD clock and data lines are left floating on the kit. Because of that the
target on the kit may wake up unexpectedly. If it is necessary to prevent this situation in your design,
you can use one of the following solutions:

1. Re-purpose the SWD clock and data lines to GPIO.

2. Use resistive pull up on these lines.
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AA1 Pin Assignment Tables
A1 PSoC 5LP GPIO Header (J8) for CY8CKIT-042-BLE, CY8CKIT-044 and
CY8CKIT-046
J8
EII el INLCOT 1o Pin PSoC 5LP Signal | | S0CSLP
Signal Description Description
PSoC .
J8_01 5LP VDD VDD J8_02 P1[2] Digital I/O
J8.03 PO[O] :Delta Sigma ADC + J8_04 PO[1] Delta Sigma ADC -
nput Input
J8_05 P3[4] SAR - Input J8_06 P3[5] SAR + Input
Jg_07 P3[6] Buffered VDAC J8_08 P3[7] Buffered VDAC
J8_09 P12[6] UART RX J8_10 P12[7] UART TX
J8_11 P12[1] SPI MISO/12C SDA | J8_12 P3[0] IDAC Output
J8_13 P12[0] SPI SCLK/I2C SCL | J8_14 P12[5] SPI MOSI
J8_15 P2[5] SPI SSEL J8_16 GND GND
A1.2 PSoC 5LP GPIO Header (J8) for CY8CKIT-042 and CY8CKIT-040
J8
: PSoC 5LP PSoC 5LP . PSoC 5LP PSoC 5LP
Pin . L Pin . e
Signal Description Signal Description
J8_01 PSoC 5LP_VDD (VDD Jg_02 P1[2] Digital I/O
Delta Sigma Delta Sigma
J8_03 PO[0] ADC + Input J8_04 PO[1] ADC - Input
J8_05 P3[4] SAR - Input J8_06 P3[5] SAR + Input
J8_07 P3[6] Buffered VDAC |[J8_08 P3[7] Buffered VDAC
J8_09 P12[6] UART RX Jg_10 P12[7] UART TX
J8_11 GND gngISO/IZC J8_12 P3[0] IDAC Output
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A1.3 PSoC 5LP GPIO Header (J8 and J9) for CY8CKIT-059 and CY8CKIT-043

J9 J8
Pin PSc_>C 5LP PSoC_ 5I_.P Pin PSc_>C 5LP PSoC_ 5I_.P
Signal Description Signal Description
J9_01 VBUS Power/VDD J8 01 GND Ground
J9_02 GND Ground Jg_02 P3[0] GPIO
Jo_03 P12[5] GPIO J8_03 P3[4] GPIO
J9_04 P12[0] GPIO/I2C_SCL |J8_04 P3[5] GPIO
J9_05 P12[1] GPIO/I2C_SDA |J8_05 P3[6] GPIO
J9_06 P12[6] GPIO/UART_RX | J8_06 PO[0] GPIO
Jo_07 P12[7] GPIO/UART_TX |J8_07 PO[1] GPIO
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